Elixir undefined function xmerl

When using some Erlang libraries that parses XML you might run into the following issue.

** (EXIT from #PID<0.305.0>) an exception was raised:
    ** (UndefinedFunctionError) undefined function: :xmerl_scan.string/1 (module :xmerl_scan is not available)

Xmerl is an Erlang library for dealing with XML files and it is not installed with Erlang from package manager by default on Ubuntu machines.

To install this missing dependency, you can use the following package.

sudo apt-get install erlang-xmerl

And everything works again.


Did you like the article? Send me a comment!